Jump to content
The King of Hate Forums

So which graphics card, do you prefer, ATI, Nvidia, or other?


Recommended Posts

  • 6 months later...
  • 3 weeks later...
  • 5 weeks later...
  • 1 year later...
On 6/5/2021 at 10:20 PM, url8 said:

ATI Radeon 9700 Pro, as it can run RapeLay.

I know that you can technically get RapeLay to run on PCs with modern graphics chips, but it requires setting up dgVoodoo, which can take some time. I would like a graphics card that doesn't require as much configuration to run this game.

Link to post
Share on other sites
  • 5 weeks later...

None of you are asking about these old graphics cards. I do have some modern PCs with a modern-ish AMD Radeon RX 580 and a laptop with a GeForce GTX 1660. It's just that I need to emulate an older graphics card to play RapeLay with the modern PCs. Also those graphics cards do not work on anything before Windows Vista (you are usually lucky if they work on anything older than Windows 10, nowadays). Whereas the ATI Radeon 9700 Pro still supports Windows 2000, so I don't have to deal with each newer and slower versions of Windows. Windows 2000 is still too slow for me unfortunately, but Windows NT 4.0 doesn't even support DirectX, which is needed for many games like RapeLay (and other Illusion games). There also aren't drivers available for this card for Windows NT 4.0 anyway. Windows 95 does support DirectX, but suffered from much worse optimization issues than Windows NT 5.x did, despite not even having Internet Explorer integration. It also lacked drivers. Usually older versions of Windows are faster, but Windows 95 is a particularly special case. It is due to how slow it is that I use Windows NT 4.0 instead, as it's almost the same thing, but much, much faster!

I wish I could still use Windows NT 4.0 to this day, but everyone stopped supporting it in the early 2000s. So if I want to play Illusion games, I had to "upgrade" to Windows 2000.

Wow, jeez, this has gone way off topic. It started out as me talking about some modern cards that don't work for Illusion games and became a rant about how everything after Windows NT 4.0 started getting worse.

Edited by url8
  • Like 1
Link to post
Share on other sites
On 7/17/2021 at 2:14 AM, url8 said:

Wow, jeez, this has gone way off topic. It started out as me talking about some modern cards that don't work for Illusion games and became a rant about how everything after Windows NT 4.0 started getting worse.

Lol! But your post above, was really interesting to read though.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...